Pit Boss Auger Issues

Traegers, Green Mountain, Smokin Tex and all other Pellet and Wood Chip Smokers

Moderator: TBBQF Deputies

Happy Grillmore
Pilgrim
Posts: 1
Joined: Mon Oct 08, 2018 1:54 pm
Contact:

Pit Boss Auger Issues

Postby Happy Grillmore » Mon Oct 08, 2018 2:21 pm

I own a Pit Boss 820FB. I have used it for over a year without any issues. Lately when firing it up it goes through start cycle then temp goes down and auger wont turn at all. I perform a hard reset and watch the auger, It is supposed to run 4 minutes, it does not do this every time. took auger out and cleaned everything. Started empty, Manual says 3 minutes from when you start in the smoke setting to get pellets to burner pot. It took 4 resets of running 4 minutes each before pellets reached the fire pot. I am guessing auger motor issues or control board. Anyone know how I can check to see if motor is bad or good? Control panel seems ok but not sure if it's internal issues. Thanks in advance.
dub'
Cowboy
Posts: 424
Joined: Sun Jul 08, 2007 1:38 am
Location: RtCoastTxExPat
Contact:

Re: Pit Boss Auger Issues

Postby dub' » Mon Oct 08, 2018 10:15 pm

T'aint funny McGee-
Moderator,move this post!
User avatar
Papa Tom
Deputy
Posts: 6242
Joined: Sat Jun 30, 2007 9:40 am
Location: Oak Point, TX
Contact:

Re: Pit Boss Auger Issues

Postby Papa Tom » Tue Oct 09, 2018 9:38 am

What you can do is swap the plugs for the fan and the auger motor then the auger should run continuously and the fan run in the periods assigned to the auger.
Since you have had the auger out I'm assuming that there are no connection or other mechanical issues so really that just leaves the controller.
tarde venientibus ossa....

Return to “Pellet Cookers and Smokers”

Who is online

Users browsing this forum: No registered users and 3 guests